EU Studio login issue

Incident Report for Appcues

Resolved

The issue has been resolved
Posted Apr 21, 2026 - 10:45 EDT

Identified

We've identified an issue logging into the EU Appcues Studio and are working on a fix. End user experiences and data collection are not impacted.
Posted Apr 21, 2026 - 09:47 EDT
This incident affected: Studio (EU).