Appcues Identify Call Failure
Incident Report for Appcues
Resolved
We have not received any additional reports of SDK or user identification issues, so considering this incident as resolved.

Note: updating the SDK to the latest version requires no action on your part, or that of your users. Updates take place behind-the-scenes and automatically when you refresh any page where the SDK is installed.

If you spot any issues, please report them to support@appcues.com.
Posted Oct 08, 2018 - 17:12 EDT
Monitoring
A new version of our SDK has been released, 3.31.0, which includes a fix for this issue. We are seeing all reporting returning to normal, but will continue monitoring this issue as customer roll onto the new SDK. If all is well, we will mark this as resolved in the next few hours.

If you spot any lingering issues, please confirm your SDK version (directions below). If you need to update (i.e. the version number is less than 3.31.0) a refresh should fix it. If you are on the newest version, please reach out to support so we can investigate.

Notes:
1. a refresh will be necessary for you and your users to receive the new SDK.
2. To confirm your SDK version, call Appcues.debug() in your browser's developer console. The SDK version number will be in the upper right hand corner.
Posted Oct 08, 2018 - 14:45 EDT
Investigating
We have discovered an issue with our processes for identifying new users. This means brand new users (or existing users on new devices) are not being identified properly, and will not see flows as intended.

A symptom of this bug is the Appcues debugger reporting the user as unidentified, despite other users working properly.

We are working now to identify the root cause and resolve the issue. Once the cause is known, we will be able to make a clearer timetable for resolution.
Posted Oct 08, 2018 - 12:57 EDT
This incident affected: api.appcues.com.