Studio Analytics Degredation
Resolved
The root cause has been identified and the query pattern that caused the issue has been mitigated.
Posted Nov 06, 2025 - 15:00 EST
Investigating
We're investigating delays returning analytics data in Studio.
Posted Nov 06, 2025 - 13:57 EST
This incident affected: studio.appcues.com.