Appcues Studio Unavailable in the EU

Incident Report for Appcues

Resolved

We've addressed the underlying issue and Studio in the EU is now available.
Posted Mar 16, 2026 - 18:19 EDT

Investigating

We're addressing an issue preventing access to studio.eu.appcues.com. US Appcues Studio is not impacted. End user content delivery and analytics data collection is not affected in either region.
Posted Mar 16, 2026 - 18:01 EDT
This incident affected: Studio (EU).