Appcues Studio Invites
Incident Report for Appcues
Resolved
The issue with inviting users to Appcues accounts has been resolved.
Posted Mar 14, 2021 - 22:52 EDT
Monitoring
We are currently experiencing an outage with our email provider, and we are unable to send account invitations to new teammates. We expect this to be resolved by Monday. If you have an urgent need to invite a teammate this weekend, please email support@appcues.com. We apologize for the inconvenience.
Posted Mar 12, 2021 - 17:12 EST
Investigating
We have identified an issue with inviting users to Appcues accounts. We are working on a solution now.
Posted Mar 12, 2021 - 14:19 EST
This incident affected: studio.appcues.com.