High latency on my.appcues.com
Incident Report for Appcues
Resolved
We've resolved the high latency on my.appcues.com.
Posted 3 months ago. Jul 16, 2018 - 10:32 EDT
Investigating
We are investigating high latency on my.appcues.com. Our end-user and server platforms are not affected.
Posted 3 months ago. Jul 16, 2018 - 10:19 EDT
This incident affected: my.appcues.com.